ambiera home ambiera home

Ambiera Forum

Discussions, Help and Support.

Create a new account, Search, or Login:
Name:  Password:    
Ambiera Forum > WebsitePainter
contact form issue
Author Text

andyz99
Registered User
Quote
2016-07-13 13:23:53

I am having a problem with a contact form which is rather frustrating. I have tried recreating the form from scratch a couple of times but cannot get away from the problem

Parse error: syntax error, unexpected '$name' (T_VARIABLE) in /homepages/10/d373707115/htdocs/inventry/contact.php on line 194




I cannot see anything causing a problem on that line or around???

I have dumped the site on http://www.inventry.computerinsight.org

Any ideas will be greatly appreciated - can't see the wood for the trees etc.....

Andy


erik
Registered User
Quote
2016-07-14 04:06:11

Are you on Mac OS X? And did you do the contact form tutorial? Did you try erasing the spaces in front of all the lines of code in your php element? Maybe it helps.


andyz99
Registered User
Quote
2016-07-14 09:08:57

Mac OSX 10.11.4
No spaces.
Yes created from scratch a few times. But then tried something different and stumbled upon something strange.... I simply copied a contact form from a different project and without changing anything it worked - great I thought. So I just changed the email address and then got the same error message. All I did was change the email address in the php code. I did this several times to make sure that I did not add/remove any other characters.

This is very bizarre....

Thanks for your help

Andy


andyz99
Registered User
Quote
2016-07-14 09:31:53

Now I've done a little research. I created a new page and added each component for a contact page a bit at a time, after each stage uploading and testing, all worked well until I uploaded the php code. I got the error message (at a diff line - but had less information) only when I added the php code that I copied from the Ambiera website Tutorial.

Does that help anyone??

Andy


erik
Registered User
Quote
2016-07-14 13:55:00

that's difficult to say without seeing the code. You should send the WebsitePainter file to ambiera support, they will be able to help you.


andyz99
Registered User
Quote
2016-07-14 16:13:01

That would be great - but how do I send them the file?


erik
Registered User
Quote
2016-07-14 18:00:06

Under support -> contact, there is a email address printed on top of the page


Create reply:


Posted by: (you are not logged in)


Enter the missing letter in: "I?ternational" (you are not logged in)


Text:

 

  

Forum Codes


Feature Code
Link [url] www.example.com [/url]
Bold [b]bold text[/b]
Image [img]http://www.example.com/image.jpg[/img]
Quote [quote]quoted text[/quote]
Code [code]source code[/code]

Emoticons


   





Software: Ambiera Light Forum. © 2008-2015 Nikolaus Gebhardt, Ambiera e.U.