Ambiera Forum

Discussions, Help and Support.

Create a new account, Search, or Login:
Name: Password:
Ambiera Forum > CopperCube > Feature requests and bug reports
Another weird bug - laptop battery
Author Text

VP
Guest
Quote
2022-05-16 09:29:46

On my latest game "Terminator", everything works fine.

However, if I unplug the power from my laptop (and run on battery power), the character wont move, but everything else works perfectly. lol.

The character animations change properly and the rest of the game still works - but the character stays in exactly the same place. ie: character wont move when keys are pressed.

When I plug the power back in, the character starts moving normally again.

Any reason why this is happening - any way to fix it? I assumed the power/batter would have nothing to do with moving the game character?

Maybe it's switching between "onboard/dedicated" graphics cards when I change from battery to plugged power - but why would this stop the character moving in the game?

Very strange.


VP
Guest
Quote
2022-05-16 09:46:02

Video example....

https://www.youtube.com/watch?v=...


VP
Guest
Quote
2022-05-16 10:10:00

Workaround: I changed the "Every few seconds" from 60ms to 200ms. It's still a bit slow when I switch to battery.

1- Maybe using battery power changes the clock-speed of coppercube?

2- I have 8 cores producing 2.8GHz, so maybe Coppercube is using only 1 core or something?

My power plan is set to "High Performance" profile.

Any help would be appreciated. Thanks


VP
Guest
Quote
2022-05-16 10:36:15

[SOLVED]

Timing problem/bug is likely caused by "V-sync" option in the windows "publish" settings.

If I turn off v-sync, everything works perfectly. If I enable v-sync, the bug occurs again on battery-power.

Will go back and check the backups of my older projects (Cas-Evac and Nekron) to see if all the timing bugs can be fixed by disabling v-sync. If they can be fixed, I will be able to continue those projects!

Using GTX-1060 (3GB) and Nvidia 512.59 driver.


count2rfeit
Registered User
Quote
2022-05-16 15:55:25

if I remember correctly, there was a discussion a couple years ago about screen tearing and using "v-sync" to fix it. But it did cause other problems, so the general consensus was not to use the "v-sync" because the little bit of screen tearing (skybox with fog?) wasn't as bad as the other problems it created...

anyway, I don't think I ever enabled it, so I'm not sure what other problems there were.


VP
Guest
Quote
2022-05-16 17:16:26

Nice one! Thanks for the info - I'll leave it disabled from now on. It looks fine without it anyway.


just_in_case
Moderator
Quote
2022-05-19 05:36:29

Can you try publishing your game as OpenGL, instead of DX9, renderer, just to confirm if it is a graphics-related issue or something else? Some of my shaders also require a dedicated GPU to work correctly, so your first guess that your laptop switches from dedicated to onboard graphics might be true.

Also, can you try running it with Max FPS and with a locked FPS of 60? Some timings-related bugs are also caused by 250 FPS.


Also Coppercube's max supported fps is 334 not 250, but to get 334 frames per second, you need to put something like 260 or 270 in the publishing setting of CC game for the fps.

Hope that info helps.


VP
Guest
Quote
2022-05-19 21:58:13

Thank you just_in_case
I ran with openGL and the character did walk (on battery power with V-sync enabled) but the entire game had glitchy lighting (flickering red/green/black)...
🔎︎


So,I switched back to DirectX, then changed "wanted frames per second" from "60" to "270". The character walked when on battery power again - although the movement was choppy - but I think it runs a bit smoother now (with a target framerate of 270) when plugged in and with v-sync disabled. Not sure how to lock the FPS to 60 but by default, I had all my projects set with 60FPS as the target.

Thanks.


just_in_case
Moderator
Quote
2022-05-21 06:36:08

Yeah, OpenGL might have different light issues. by default the game is locked to 60FPS, so you don't have to do much there for the FPS target. I still think the issue is related to the dedicated GPU. Anyways am glad that disabling v-sync fixed your issues.


Create reply:


Posted by: (you are not logged in)


Enter the missing letter in: "Inte?national" (you are not logged in)


Text:

 

  

Possible Codes


Feature Code
Link [url] www.example.com [/url]
Bold [b]bold text[/b]
Image [img]http://www.example.com/image.jpg[/img]
Quote [quote]quoted text[/quote]
Code [code]source code[/code]

Emoticons


   






Copyright© 2020 Ambiera e.U. all rights reserved.
Privacy Policy | Terms and Conditions | Imprint | Contact