Ambiera Forum

Discussions, Help and Support.

Ambiera Forum > CopperCube > Help with CopperCube
yet another problem when moving scene nodes

tuxthesofa
Registered User
Quote
2024-01-30 17:09:51

so i fixed the gate issue, but now i want to teleport the camera, so i put a change position of scene node behaviour, put the xyz there, but when i clicked it, camera is teleported to other side of room, not to another building. i even made a invisible billboard and made the behaviour set relative to scene node and made it relative to billboard but still doesnt work!!! pls help


o139
Registered User
Quote
2024-01-30 17:32:26

its probably because you have collide when moved on the camera then it will not go through walls

if my guess is right then there is a ccb javascript function to move objects without collision .. i also beleave that in the next version of ccb there will be move without collision action


tuxthesofa
Registered User
Quote
2024-01-30 17:37:01

wrote:
its probably because you have collide when moved on the camera then it will not go through walls

if my guess is right then there is a ccb javascript function to move objects without collision .. i also beleave that in the next version of ccb there will be move without collision action

aw man, i tried to work around of it by changing camera, deleting the old camera, and teleporting the second camera to other building, but the gun bugged out so i gave up


Create reply:


Posted by: (you are not logged in)


Enter the missing letter in: "Inter?ational" (you are not logged in)


Text:

 

  

Possible Codes


Feature Code
Link [url] www.example.com [/url]
Bold [b]bold text[/b]
Image [img]http://www.example.com/image.jpg[/img]
Quote [quote]quoted text[/quote]
Code [code]source code[/code]

Emoticons


   






Copyright© Ambiera e.U. all rights reserved.
Privacy Policy | Terms and Conditions | Imprint | Contact