Ambiera Forum

Discussions, Help and Support.

Ambiera Forum > CopperCube > Help with CopperCube
Blender import export Textur Problem

oldman1970
Registered User
Quote
2024-02-18 11:11:10

Hello everyone !
I have a problem when I import an object created with Blender into Coppercube and then select a texture, it is not displayed correctly. How can I solve this?
I added pictures, I hope you understand what I mean.
Thanks

https://1drv.ms/i/s!AgpvpQvjp0mogR2V9bLt9s76c9X6?e=xTBUv4

https://1drv.ms/i/s!AgpvpQvjp0mogR4KE52tk7DXgNBR?e=xaKOdC


vp
Guest
Quote
2024-02-20 09:56:04

Looks like the texture is working, it's just too big - try changing the scale of the texture in coppercube - right click>modify selection>set planar coordinates.

If you export as obj instead, the .mtl file tells coppercube how to apply the texture - so obj should work automatically on import - as long as you put the obj/mtl/textures in the same folder.

FBX need embedded/baked textures for coppercube - otherwise you'll need to set them inside coppercube after import.


just_in_case
Moderator
Quote
2024-02-21 14:44:56

Do as @VP suggested, if it still doesn't work out for you. Then try clearing "vertex color" by right-clicking the model in CopperCube and then go to modify the selection and then clear vertex color.


oldman1970
Registered User
Quote
2024-02-21 16:40:45

Thanks ,That works so Far!

But now i have the next problem
pls see

https://1drv.ms/i/s!AgpvpQvjp0mogSMv_sOv0Upzrwfa?e=BMn6FC

greets

Oldman


just_in_case
Moderator
Quote
2024-02-22 03:46:12

Hi there, it seems to be an issue with the UV maps, or texture Wrapping.

You can try changing the Texture Wrap method CC use for a material by default, in order to do so go to your irredit/irrlicht properties for the model, select the material if you have multiple materials then select the one that is having this issue.

Then scroll down to the last, and you will see option "Texture Wrap1" Try changing different toggles if it sorts out your issue. If it doesn't then you can either manually rotate the textures using Polygon Editing tools by selecting the triangles that has UV upside down.

Or you can try re-exporting from the blender in a different format. Also make sure to check that UVs are properly mapped in the blender itself, if the UVs are not correctly mapped to the model in the blender then first correct them there, before exporting it to use in CopperCube.


Create reply:


Posted by: (you are not logged in)


Enter the missing letter in: "Internati?nal" (you are not logged in)


Text:

 

  

Possible Codes


Feature Code
Link [url] www.example.com [/url]
Bold [b]bold text[/b]
Image [img]http://www.example.com/image.jpg[/img]
Quote [quote]quoted text[/quote]
Code [code]source code[/code]

Emoticons


   






Copyright© Ambiera e.U. all rights reserved.
Privacy Policy | Terms and Conditions | Imprint | Contact