Ambiera Forum

Discussions, Help and Support.

Ambiera Forum > CopperCube > Feature requests and bug reports
Missing Plugins tab

dekon_17
Registered User
Quote
2024-06-23 22:13:19

Aparently, I had to reinstall Windows on my PC, and now, for some reason, I am missing "Plugins" tab. It was there before reinstallation, inside "Edit" tab, now it's just gone. Is there any way to fix this? I tried reinstalling Coppercube, it did not help.


VP
Guest
Quote
2024-06-24 13:30:33

A lot of old software suffers this issue with GUI on newer versions of windows. It's because Coppercube is not "DPI aware" so the GUI does not scale properly when it changes resolution.

If your screen is a higher DPI, your windows scaling is probably above 100%, this will affect how the coppercube GUI is drawn - ie: it will not be drawn correctly (parts will be completely missing.

If this is your issue, you can either set scaling to 100% globally - or right-click coppercube.exe, go to properties, compatibility, dpi scaling override, click "override scaling>performed by application". This should restore the GUI scaling to default when you next launch coppercube, the issue will now be that the GUI looks massive and the menu will be too big to fit on the screen - but you should now have arrows to "expand the items" that are offscreen.

It's possible that your issue is caused by something else but scaling is an easy check/fix.

Hope it works.


VP
Guest
Quote
2024-06-24 13:36:53

...if you set global scaling to 100%, everything (all software GUI's) will be scaled perfectly (ie:no missing DPI) but, depending on the DPI of your screen, everything may look tiny (too small to read).

For me, since buying a new laptop (with a high density screen), I have to use global scaling of 175% - otherwise Coppercube is super-tiny, but when I open coppercube at 175%, the GUI is mmmmaassssiiiivvve and I have to use arrows to scroll around inside it. No way to fix it without the source-code unless someone can make a wrapper somehow?


dekon_17
Registered User
Quote
2024-06-24 14:18:04

So, none of this helped. Tried various other parameters - nothing. Checked on my laptop, engine seems to be working fine, despite the same display parameters (1920x1080, 60Hz). But, just with current OS (I am not sure if this is caused by it or not, it is somewhat of a pirated thing after all), it does not want to work. Could it possibly be that I am missing some essential components? I remember trying to use Coppercube on a college PC, the display was in just an HD resolution or something, I swear I could count each pixel on it. But, that PC was unable to draw anything 3D, seems like it had no DirectX or OpenGL, probably a lot more stuff was missing as well. And the engine was missing "Plugins" tab, too. Though, it could possibly be due to a free edition of the engine? I don't remember wether it exists there or not.

Right now, that's how this menu looks:
🔎︎

"Plugins" must be just under the "Modify Polygons". It is the only tab I am missing, as far as I know, which is weird if DPI causes such issue. Wouldn't it break or hide more things?


vp
Guest
Quote
2024-06-24 15:43:46

Yeah, it would hide a lot of things if it was a scaling issue, not just the plugins folder. In that case, it could be a permissions issue as the coppercube plugins are held in documents folder. I'm just guessing - but if you run coppercube as admin, it will be able to access the personal folders (including the plugins folder)?


vp
Guest
Quote
2024-06-24 15:54:30

also maybe consider trying coppercube v5, just to test if it's an issue with your PC or maybe just a particular issue with ccb v6 updates?


dekon_17
Registered User
Quote
2024-06-24 18:34:55

Tried to launch as administrator, it's a no-go. For now, guess I'll count the problem at my PC. Will try to find a way to fix it then... Somehow. Thanks for help regardless.


vp
Guest
Quote
2024-06-24 19:07:00

You're welcome. No worries, shame we couldn't get it working properly. I'll keep thinking for a possible solution and hopefully other people have some ideas for you too.


Guest
Guest
Quote
2024-06-24 20:43:19

@dekon_17

Is your system language in Cyrillic script? I seem to recall seeing a post on here about that issue; it was from a Japanese guy. He had the same issue. Niko said he'd look into it, but I guess he never did. The issue was something about it not being a Latin script. Unfortunately, I can't find the post because the search engine in this forum is garbage.


Guest
Guest
Quote
2024-06-24 20:59:52

I'm seeing a couple different solutions to this problem. The easiest might be to change your system locale like:

Change System Locale:
--Go to Control Panel > Region.
--In the Administrative tab, click Change system locale.
--Select English (United States) and restart the computer.

If this works, we at least know what the issue is. Another solution is more complex and requires symlinks. Apologies if this is not your issue, as I am shooting in the dark here.


dekon_17
Registered User
Quote
2024-06-25 09:25:24

Tried to do this, but not sure I've done it right. You know, just had to navigate through one language with guidance on a different one. The only region-related option I found was regional standarts for time and date. Changing it to english did nothing to Coppercube... Obviously. Either it's me misunderstanding you, or it's just not the issue. Also, are there any requirements for Coppercube? I remember having various C++ or C, VS and XNA related components on my PC back when it was all working well.


Guest
Guest
Quote
2024-06-25 10:19:17

Maybe this will help?

https://i.ibb.co/c1xBH8r/explore...

You don't need to keep it like this, we just need to see if it corrects your issue to identify the cause of the problem. I doubt it has anything to do with what you mentioned. It's most likely a problem with how the Documents folder path is setup. My path to my plugins folder is like this:

C:\Users\User\Documents\CopperCube\plugins

What does yours look like?


Guest
Guest
Quote
2024-06-25 10:28:33

I'm assuming something like this breaks CopperCube:

C:\Users\???????\Documents\CopperCube\plugins


Guest
Guest
Quote
2024-06-25 10:31:54

Umm... Something like this but in Cyrillic:

C:\Users\Aleksei\Documents\CopperCube\plugins


Guest
Guest
Quote
2024-06-25 10:45:31

Maybe also do this step:

--Select English (United States) and restart the computer.

But try changing it to Russian (or whatever language is your username).

If the entire path of your Documents folder is using Latin characters, then this isn't your problem most likely.


Create reply:


Posted by: (you are not logged in)


Enter the missing letter in: "Inter?ational" (you are not logged in)


Text:

 

  

Possible Codes


Feature Code
Link [url] www.example.com [/url]
Bold [b]bold text[/b]
Image [img]http://www.example.com/image.jpg[/img]
Quote [quote]quoted text[/quote]
Code [code]source code[/code]

Emoticons


   






Copyright© Ambiera e.U. all rights reserved.
Privacy Policy | Terms and Conditions | Imprint | Contact